DueDil disabling TLS 1.0  | DueDil

DueDil disabling TLS 1.0

What's Happening?

From April 2nd 2018, DueDil will be discontinuing support for browsers which are not compatible with TLS 1.1 or higher, in order to comply with industry standards for security and data integrity.

Am I affected?

All modern browsers support at least TLS 1.1, so you should not be affected, but if you are using an older browser, you should upgrade as soon as possible, or contact your IT Administrator. The following link has a table which shows which browser versions support TLS 1.1 https://caniuse.com/#feat=tls1-1

What should I do if I'm using an older browser?

If you are using an unsupported browser, you should considering updating to a newer version as soon as possible, for the sake of your own online security and data protection. We need to make this change for the security of all of our customers, and unfortunately you will no longer be able to access DueDil on an unsupported browser. If you have any more questions, please contact our support desk.